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About This Guide

Using SOFTIMAGE®|3D with SOFTIMAGE®|XSI™ describes the 
SOFTIMAGE|3D data you can import into XSI.

• Chapter 1: Fundamentals of Importing—introduces you to the ways you 
can import data into XSI and provides an overview to the Import from 
SI|3D Scene/Model command.

• Chapter 2: Preparing for Import into XSI—tells you about some of the 
major differences between SOFTIMAGE|3D and XSI and helps you 
choose what to import for re-use in XSI.

• Chapter 3: Importing a SOFTIMAGE|3D Scene—shows you a typical scene-
file import and uncovers the hiding places of some of your scene elements. 

• Chapter 4: Conversion Table—summarizes what XSI currently imports 
when you choose the Import from SI|3D Scene/Model command.

For the sake of brevity and clarity, from here on SOFTIMAGE|XSI 
will be referred to as XSI.
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Where to Find Information

Refer to Release Notes, an online listing of known problems and limitations for this 
version. Also includes workarounds and supplemental information. Access through the 
web at www.softimage.com > support.

Work through Tutorials to learn the features in the context of basic productions.
This is a full-color set of lessons showing you step-by-step how to perform typical tasks.
You can install the scenes from the Software CD. (Choose Custom install when installing XSI). Then 
choose the Content option to install the Tutorials project.

The Softimage Discussion Group

You can join the worldwide network of Softimage users exchanging ideas and techniques 
by e-mail. To find out more, e-mail majordomo@softimage.com. Leave the Subject line 
empty and type the word “help” in the body of your mail message.

Start with the Setup Guide to install and license all components.
Setup Online Help is also available as you go through the process.
We recommend you choose Custom install so that you can perform the tutorials.

Follow the Guided Tour (available from the Online Library CD).
This is a set of videoclips that provide overviews of features and tools.

The XSI package includes a comprehensive set of learning materials. Use this 
Roadmap to find the information you need to get up and running quickly and 
effectively.



Where to Find Information

 Using SOFTIMAGE|3D with SOFTIMAGE|XSI • 9

The Global Index & Glossary is an 
index to all user guides and Tutorials; 
a glossary of terms; and a list of 
books, videos, and web sites related 
to the 3D animation industry.

Using SOFTIMAGE|3D with 
SOFTIMAGE|XSI provides tips and 
techniques about using the two 
software packages. (Available from 
the Online Library CD and 
softimage.com > support only)

Online Help
On-screen reference 
information on interface 
elements, commands, and 
parameters. There are two 
ways to access it: 

•Click the ? button in any 
property editor or tool view.

•Choose Help > 
Contents and Index
from the main-menu bar.

The Online Library CD
The Online Library contains 
the Guided Tour and all the 
XSI and some mental ray 
documentation in electronic 
form in both PDF and HTML 
formats. (See next page for 
how to use.)

The user guides contain 
conceptual information and 
procedures on how to use 
specific tools. These comprise:

•Fundamentals
•Animating
•Modeling & Deformations
•Shaders, Lights & Cameras
•Rendering

Pin up the XSI Interface Layout and the Quick Reference Card to help you
become familiar with the interface and keyboard shortcuts.

HTML Scripting Reference
An HTML-based reference help on the syntax
for all scripting commands and arguments.
It appears in your default HTML browser.
Click on the icon (above) to open the script editor, 
then click Help > Scripting Reference or press F1.
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Using the Online Library

The Online Library contains the Guided Tour and all the XSI and some mental 
ray documentation in electronic form in both PDF and HTML formats. 

For full-text searching and printing, we recommend PDF format. If you do 
not have Acrobat Reader installed, you can install it it free of charge from the 
Online Library CD: Follow the instructions in the readme file on the CD.

To access the Online Library

1. Insert the Online Library CD in your disk drive.

2. Open one of the following documents:

- mainmenu.pdf (PDF format)

- mainmenu.htm (HTML format)

Document Conventions

The following are ways that information is displayed in the XSI 
documentation.

Typography Conventions

Type style Usage

Bold Menu commands, dialog-box and property-editor options, and 
file and directory names.

Italics Definitions and emphasized words.

Courier Text that you must type exactly as it appears. For example, if you 
are asked to type mkdir style, you would type these 
characters and the spacing between words exactly as they are 
appear in this book.

> The arrow (>) indicates menu commands (and subcommands) in 
the order that you choose them: Menu name > Command 
name. For example, when you see File > Open, it means to 
open the File menu and then choose the Open command.
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Visual Identifiers

These icons help identify certain types of information:

Keyboard and Mouse Conventions

XSI uses a three-button mouse for most operations. These are referred to as 
the left, middle, and right mouse buttons. In many cases, you will use the 
different buttons to perform different operations; always use the left mouse 
button unless otherwise stated.

This table shows the terms relating to the mouse and keyboard.

Notes are used for information that is an aside to the text. Notes are 
reminders or contain important information.

Tips are useful tidbits of information, workarounds, and shortcuts 
that you might find helpful in a particular situation.

The 3D icon indicates information about differences in workflow or 
concepts between SOFTIMAGE|3D and XSI. You will find these very 
helpful when working with the two products.

Warnings are used when you can lose or damage information, such 
as deleting data or not being able to easily undo an action. Warnings 
always appear before you are about to do such a task!

The two-button mouse is not supported in XSI.

When this term is 
used...

...it means this

Click Quickly press and release the left mouse button. Always use 
the left mouse button unless otherwise stated.

Middle-click Quickly press and release the middle mouse button of a 
three-button mouse.

Right-click Quickly press and release the right mouse button.

Double-click Quickly click the left mouse button twice.

Shift+click, 
Ctrl+click, Alt+click

Hold down the Shift, Ctrl, or Alt key as you click a mouse 
button.

Drag Hold down the left mouse button as you move the mouse.

Alt+key, Ctrl+key, 
Shift+key

Hold down the first key as you press the second key. For 
example, “Press Alt+Enter” means to hold down the Alt key 
as you press the Enter key.
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This chapter introduces you to the ways you can import data into XSI and 
provides an overview to the Import from SI3D Scene/Model command.

XSI provides a robust scene and model importer that preserves much of what 
you have already created in SOFTIMAGE|3D. This guide is designed to help 
you make informed decisions about what you can and should import from 
SOFTIMAGE|3D for re-use in XSI. 

About the Scenes Used 
in This Guide

The scenes used to illustrate the concepts described in this guide are from 
Tightrope, a five-minute, all CG–animated short film, written and directed by 
Daniel Robichaud of Digital Domain. Two characters, The Jester and The Suit, 
encounter each other on a tightrope. One playful, the other not, their 
encounter has a lasting impact on them both. For more information and 
stunning stills from this short, visit www.d2.com/tightrope/main.html.

You can reuse models and animated characters from 
SOFTIMAGE|3D. The trick is learning what you should 
import to take full advantage of the new animation 
and rendering features in XSI. 



16 • SOFTIMAGE|XSI  

Chapter 1 • Fundamentals of Importing

Exchanging Data: An Overview

Version 1.0 of XSI provides three pathways to exchange information between 
it and SOFTIMAGE|3D.

• File > Import SI3D Scene/Model reads a *.dsc or *.hrc file and imports it 
into XSI.

• File > Import/Export IGES File reads an *.iges or *.igs file and imports it 
into XSI.

• Sources > Import/Export Action from/to SI3D Anim File in the Animate 
toolbar reads *.ani and *.key files and applies them to hierarchies already 
imported or created in XSI. 

This document deals with the Import SI3D Scene/Model command. Refer to 
the XSI user guides for information about the other options mentioned above.

Before You Begin

Before importing scenes and objects into XSI, you should become familiar 
with this new software. Try the lessons in the Tutorials book. Consult the user 
guides—they often give you additional information about how 
SOFTIMAGE|3D differs from XSI. 

These commands let you 
import SOFTIMAGE|3D 
scenes and IGES files.

Exchange animation data 
between SOFTIMAGE|3D 
and SOFTIMAGE|XSI.

Look for this symbol in the XSI user guides. They accompany 
information relevant to SOFTIMAGE|3D users.
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What Gets Imported: An Overview

When you import a scene from SOFTIMAGE|3D, most of its contents are 
imported. When the importer encounters an object that is not supported in 
XSI, it will often convert it to one that is. For example, you cannot create 
Patch objects in XSI, so the importer converts these to NURBS objects, which 
are supported. 

Where to Go from Here Chapter 2: Preparing for Import into XSI on page 19 helps you select the 
elements most appropriate for re-use in XSI.

Chapter 3: Importing a SOFTIMAGE|3D Scene on page 31 shows you a typical 
scene file import and uncovers the hiding places of some of your scene elements. 

Chapter 4: Conversion Table on page 41 provides details about what is 
imported and what isn’t. 

This low-resolution control rig 
imports well into XSI. 

Polygonal and NURBS objects are 
imported with their materials, textures, 

and rendering properties intact.

If objects were animated or were envelopes 
for skeletons, they still deform as they 

would in SOFTIMAGE|3D. 

When you play back the animation, the scene uses the 
same start and end frames as in SOFTIMAGE|3D.

The named selections you’ve
set in your SOFTIMAGE|3D

scene are preserved and
imported.

Visibility and selectibility in
your SOFTIMAGE|3D scene

are preserved and imported.
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Chapter 2 Preparing for Import into XSI



20 • SOFTIMAGE|XSI  

Chapter 2 • Preparing for Import into XSI



 Using SOFTIMAGE|3D with SOFTIMAGE|XSI • 21

This chapter tells you about some of the major differences between 
SOFTIMAGE|3D and XSI and helps you choose what to import for re-use in XSI.

The File > Import SI3D Scene/Model command imports almost everything 
contained in your SOFTIMAGE|3D scene. However, depending on what you 
want to do, you may find it better to import only the elements you need or 
only the elements that will allow you to build your scene “the XSI way.” For 
example, you cannot connect imported material properties to other nodes in 
XSI’s render tree. If you want to shade and render your scene in XSI, 
importing materials and textures may not be your best choice. 

The following sections describe the major differences between 
SOFTIMAGE|3D and XSI as well as the pros and cons of importing various 
elements from SOFTIMAGE|3D.
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Character Rigs

You can import a NURBS or polygonal character and continue to animate it 
as you would in SOFTIMAGE|3D. However, articulated chains imported from 
a SOFTIMAGE|3D scene retain their original hierarchical structure, which 
means that an effector’s orientation and position will be global, not local.

XSI offers a better solution for character rigging: When you create chains in 
XSI, the effector is the child of the chain root. This allows you to create local 
animation on the effector that can be translated with the root. In other words, you 
can drag the entire hierarchy without the effector wanting to “stick” to the scene’s 
global coordinates as they do in SOFTIMAGE|3D. You no longer have to constrain 
a null to the effector and parent it to the chain root. 

You can convert SOFTIMAGE|3D skeletons to XSI ones by reparenting the 
effectors and changing the effector’s properties (see below). However, if the 
skeleton is animated, its animation is global and you’ll need to copy all the 
fcurves to local coordinates (you can do this from the Animation Editor), 
which in most cases, may be a daunting task. 

If you want to rig your character completely in XSI, you can simply import the 
model in its default pose.

For more information about animating with skeletons, refer to the XSI 
Animating guide.
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Preserving Envelope 
Weights on 
Patch Objects

If you import your SOFTIMAGE|3D character but its envelope is Patch, the 
importer will convert the object to NURBS and reset the envelope weighting, 
which will delete any weight modification you’ve done to the envelope. You 
can, however, avoid this by doing the conversion yourself in SOFTIMAGE|3D 
and importing the converted object.

To preserve envelope weights on Patch objects

1. Save the envelope weights using the Skin > weightCopy command in the 
Actor module.

2. Convert the object to a NURBS or polygonal object using the Effect > 
Convert command in the Model module.

3. Apply the envelope weights to the converted object using the Skin > 
weightPaste command in the Actor module.

For more information about these commands, refer to the SOFTIMAGE|3D 
Reference Guide.

What an imported SOFTIMAGE|3D articulated chain 
looks like: The effector is parented to the last bone in 
the chain and only inherits scaling from its immediate 
parent when it’s transformed locally.

What an articulated chain looks like in XSI:
The effector is parented to the first bone in the chain, 
and it inherits position, orientation, and scaling from 
its immediate parent when it’s transformed locally.
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Materials, Textures & Shaders

Any material or texture attribute you’ve applied to a model will import into 
the Material property page, which you can access from the explorer.
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You can modify the imported parameters. You cannot, however, build a 
render tree from these parameters; that is, you cannot add additional textures 
or nodes to augment the effect. If you want to do this, delete the imported 
material and replace it with one of the new XSI surface shaders and build from 
there as described in Applying and Editing Shaders in Chapter 2 of the XSI 
Shaders, Lights & Cameras guide.

SOFTIMAGE|3D 
mental ray® Shaders

The importer supports all of the SOFTIMAGE|3D mental ray shaders. 
However, like imported material parameters, you cannot use the render tree 
to augment the effect; you can only modify the imported parameters.

Shading and 
Rendering Plug-ins

Objects modified by Softimage plug-ins (such as RenderMap and 
SetVertexColour) will import.

Any object with a “persistent” effect (anything that had parameters that you 
could modify using Info > Custom Effect) will import into XSI, but the 
parameters will not. You will see the object, but the plug-in is no longer 
available to modify the parameters. There are two exceptions to this: 
ToonAssistant and FXDirector. Because these effects are based on mental ray 
shaders, if you freeze the effects before importing them, you will be able to 
continue modifying the shader parameters in XSI. If you do not freeze the 
effects, the shader parameters are not imported into XSI. 

Materials in XSI don’t have 
quite the same function as 
they do in SOFTIMAGE|3D. 
What were called materials 
are now more accurately 
named surface shaders.

The Material node in the 
explorer acts like a 
container for all of the 
possible shaders that can 
be applied to an object.

Notice that the texture 
imports as a material 
property.
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Third-Party Plug-ins

Third-party persistent effects will not import into XSI.

Third-Party Plug-ins 
Based on mental ray 
Shaders

The importer will not import shader parameters from third-party plug-ins 
based on mental ray shaders. 

Everything’s a Shader! XSI uses mental ray version 2.1 rendering software for all shading and 
rendering attributes. Some SOFTIMAGE|3D attributes will be converted to 
mental ray 2.1 shader parameters (some camera parameters, for example). 
There may be instances when animated parameters do not import properly. 
This may be caused by there being no one-to-one relationship between a 
SOFTIMAGE|3D attribute and a mental ray 2.1 parameter. Non-animated 
properties, however, should import correctly.

UV Texture 
Manipulation

XSI version 1.0 does not offer the same level of polygon UV texture 
manipulation that SOFTIMAGE|3D does (via its Paint tool). You may want to 
complete UV texture manipulation in SOFTIMAGE|3D before importing the 
object into XSI.

Note that freezing the effect will delete any animation you’ve applied 
using the plug-in.
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Models

Importing NURBS or polygonal models is the simplest starting point and will 
allow you to take full advantage of XSI’s IK, surface shading, and rendering 
capabilities. 

Completing Polygonal 
Models in 
SOFTIMAGE|XSI

XSI version 1.0 does not offer the same number of polygonal modeling tools 
as SOFTIMAGE|3D does. You may want to complete your polygonal model in 
SOFTIMAGE|3D before importing into XSI.

Modeling Plug-ins Any object with a “persistent” effect (anything that had parameters that you 
could modify using Info > Custom Effect) will import into XSI, but the 
parameters will not. You will see the object, but the plug-in is no longer 
available to modify the parameters. 

Third-Party Plug-ins

Third-party persistent effects will not import into XSI.
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Animation

You can import most types of animation, but there are some things that either 
import oddly or don’t import at all. Animated branch and node deformations 
(by curve or surface) import into XSI but do not look the same, although you 
can adjust them once they’re imported. 

Although wave, quickstretch, particle, collisions, simulations, and dynamics 
are not imported, you can create all these effects (or similar effects) in XSI.

Expressions and 
Constraints

SOFTIMAGE|3D expressions and constraints import into XSI. However, the 
order in which they are evaluated is different. For example, in 
SOFTIMAGE|3D you can apply a direction constraint to an object and also 
assign an expression to the object that controls its Y rotation. In XSI, you can 
do this as well, but only the constraint will work.

When you import into XSI an object that uses both a constraint and an 
expression, messages will appear in the command log suggesting how you can 
replace the constraints with expressions so that the object will behave as it did 
in SOFTIMAGE|3D. For example:

WARNING : "3093 - The following expression(s) could be created to compensate for a constraint:

WARNING : "3055 - PosConst_ExpY_1-0.cube1.kine.global.posx = PosConst_ExpY_1-0.cone1.kine.global.posx

WARNING : "3055 - PosConst_ExpY_1-0.cube1.kine.global.posz = PosConst_ExpY_1-0.cone1.kine.global.posz

WARNING : "3094 - CnsPos on cube1 could be replaced with the previous expression(s)

In the case of multiple constraints, the suggestion may not be appropriate. See 
Before You Import a SOFTIMAGE|3D Scene on page 33 for more information 
about the command log.
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B-Spline Curves and 
Path Animation

Path animations on closed B-Spline curves may not import correctly. When it 
is converted to a NURBS curve, the first control point is not at the same 
position as the original curve. Convert the curve to NURBS in 
SOFTIMAGE|3D first—you’ll have the same problem, but you can adjust it 
before importing.

Animating Plug-ins Any object with a “persistent” effect (anything that had parameters that you 
could modify using Info > Custom Effect) will import into XSI, but the 
parameters will not. You will see the object, but the plug-in is no longer 
available to modify the parameters. 

Third-Party Plug-ins

Third-party persistent effects will not import into XSI.
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Chapter 3 Importing a SOFTIMAGE|3D Scene
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This chapter shows you a typical scene-file import and points out the hiding 
places of some of your scene elements. 

Before You Import a SOFTIMAGE|3D Scene

Before importing a scene or model into XSI, you may want to enable 
command logging. When you import a SOFTIMAGE|3D scene into XSI, 
messages appear in the command box in the lower-left side of the interface. 
The messages tell you about conversions that were made to certain objects.

You can also store these messages in a command log. This will be particularly 
useful when you’re importing large and complex scenes. For information 
about storing the messages in a command log, see The Command Log in 
Chapter 7 of the XSI Fundamentals guide.
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Importing the Scene

When you import a scene into XSI, it must be in *.dsc format, or *.hrc format. 

To import a scene created in SOFTIMAGE|3D

1. From the main-menu bar, choose File > Import SI3D Scene/Model to 
display a browser.

2. Navigate to the folder that contains the scene you want to import.

3. Select the scene file to be imported. Its name appears in the File name text box.

- To select a SOFTIMAGE|3D scene file (.dsc), make sure that the Files 
Types text box is set to Scene Files (*.dsc).

- To select SOFTIMAGE|3D model file (.hrc), make sure that the Files 
Types text box is set to Model Files (*.hrc).

4. Click Open. The imported scene’s contents are added to the current scene.

Watch the command box at the bottom of the interface. When the import is 
complete, you can display all the messages in the Script Editor. Click the 
exclamation point (!) icon to open the editor. 

For more information about the Script Editor, see Chapter 7: Commands & 
Scripts in the XSI Fundamentals guide.

Make sure the scene is in a SOFTIMAGE|3D database before 
importing it.

If the SOFTIMAGE|3D DatabaseDir. rsrc file is installed on your 
computer, use the Path button to display your SOFTIMAGE|3D 
databases. You can also drag and drop from the Windows NT 
Explorer.

The Script Editor displays all the 
messages that occurred while 
the SOFTIMAGE|3D scene was 
being imported.
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A First Look

This section shows you what happens when a SOFTIMAGE|3D scene is 
loaded into XSI. 

When you import your SOFTIMAGE|3D scene, the scene is placed in a new 
model, which you can see in the explorer.

For more information about the concept of models in XSI, refer to the XSI 
Fundamentals guide.

You can select everything under this 
model and scale its contents relative the 
scene contents. If you want everything 
at the Scene level, drag and drop them 
on the Scene node.
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Many of the attributes that you applied to your objects, like selectibility, 
visibility, and named selections, are imported as well.

The previous example shows how a SOFTIMAGE|3D named selection is 
imported and displayed in the explorer. Named selections appear as group nodes 
in the explorer. Click on them to select the objects assigned to the selection.

Materials only appear if you choose to show them in the explorer—choose 
Show > Materials from the explorer. Textures appear only in the material’s 
property page. 

When you expand the model node, you 
see the scene objects. Use the options in 
the Show menu to display even more 
information in the explorer.
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Shared materials appear as group nodes in the explorer. Click the node to see 
what objects share the material.

Local material and textures appear under the object’s Cluster node.

In an explorer choose Show > 
Materials, then double-click the 
group’s material node to display 
its property page. In this case, the 
shared materials and textures for 
The Jester’s eyelashes appear.

Choose Show > All 
Nodes, then choose 
Polygon Mesh > 
Clusters.
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Shaders

The importer supports all the SOFTIMAGE|3D shaders. 

This table describes where to find the imported SOFTIMAGE|3D shader 
parameters:

Fog, Depth-fading & Ambience

Fog and depth-fading parameters are stored in the soft_fog shader. To see this 
shader, display Passes in the explorer, then choose to show Local Properties 
and All Nodes. 

Ambience is converted to ambient lighting. This node is available at the Scene 
level in the explorer.

Improving Playback If you have set your frame step to 0 in your SOFTIMAGE|3D scene, the 
importer does not set the equivalent playback setting in XSI. To improve 
playback in your imported scene, choose the Playback menu at the bottom of 
the screen (near the playback controls) and choose Real-Time Playback. Refer 
to the XSI Animating guide for more information about improving playback 
quality in XSI.

If Your Scene 
Is Too Bright

There is a default light in the XSI default scene. When you import your 
SOFTIMAGE|3D scene, the default light is not replaced. If your imported 
scene seems overly bright, delete the default light. 

If Your Textures 
Appear to Be Flipped

Texture may appear flipped in the Textured view. When you draw a render 
region, the texture will appear correctly.

3D shader type How to find in XSI

Camera Display the camera rendering properties.

Flares Display the light properties.

Materials Display material properties.

Output Display the pass node.

Texture Display material properties.

Volume Display light properties.
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SI3D Scene/Model Importer

Here is a summary of what XSI currently imports when you choose the 
Import from SI3D Scene/Model command. 

Models

Element Imported? Notes and exceptions Workarounds

Polygon Meshes Yes If the polygonal object has holes, the 
importer triangulates the polygon mesh. 
May lose surface approximation 
attributes.

NURBS (Surfaces 
and Curves)

Yes

Patches Yes The object is converted to a NURBS 
surface. If the object was an envelope, the 
envelope weights are deleted. Clusters are 
also deleted. 

See Preserving Envelope Weights on 
Patch Objects on page 23.

Linear, Bézier, 
Cardinal, and B-
Spline Curves

Yes The object is converted to a NURBS curve. 
Clusters are deleted.

Text/Faces Yes The object is converted to polygon mesh. In some cases, the object may import as a 
null. If this is the case, convert the object 
to polygon or NURBS in SOFTIMAGE|3D 
first.

Meta-Clay Yes The objects is converted to polygon mesh. 
Note that rigid envelopes do not import.

Instances Yes Instances are expanded. Expressions and 
constraints are not copied to expanded 
instances. 

If the imported instances display 
undesirable results in XSI, expand the 
instances in SOFTIMAGE|3D first and then 
re-import.

Relational 
Models

Yes Relational models are imported, but the 
modeling relation is not preserved.

Global 
Envelopes

Yes If the envelope is a Patch object, the 
envelope weights are not imported.

See Preserving Envelope Weights on 
Patch Objects on page 23.

Local Envelope Yes If the envelope is a Patch object, the 
envelope weights are not imported.

If you have applied deformation 
parameters or curves, these do not 
import. 

See Preserving Envelope Weights on 
Patch Objects on page 23.

Automatic 
Envelope

Yes If the envelope is a Patch object, the 
envelope weights are not imported.

See Preserving Envelope Weights on 
Patch Objects on page 23.

Rigid Envelopes No
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Materials, Textures 
& Rendering

Grouped 
Skeletons

Yes Objects grouped as a skeleton only import 
if they are assigned to an envelope.

If you import a scene which contains a null 
used as a skeleton and a local texture is 
applied, if converted from Patch, the 
textures appear to swim on the envelope. 
You may be able to resolve this problem 
by converting the object to polygon or 
NURBS in SOFTIMAGE|3D first.

Envelope 
Weights

Yes If the envelope is a Patch object, the 
envelope weights are not imported.

See Preserving Envelope Weights on 
Patch Objects on page 23.

Bounding 
Volumes

Yes Bounding volumes are imported as 
implicit primitives. Note that you cannot 
deform implicit geometry in XSI by 
manipulating its points.

Shared Models Yes

Wireframe 
Colors

No Note, however, that joint and vertex 
assignments colors are imported.

Element Imported? Notes and exceptions Workarounds

Element Imported? Notes and exceptions Workarounds

Materials Yes Local materials appear under the object’s 
node > Polygon Mesh > Clusters.

Shared materials appear under group 
nodes. If materials are shared, applied 
expressions may not be imported.

Some animated properties may not import 
properly. This is due to the conversion that 
occurs when some SOFTIMAGE|3D 
attributes are converted to mental ray 2.1 
parameters—there may not be a one-to-
one correlation between all parameters.

2D Textures Yes Local textures appear in the Material node 
found under the object’s node > Polygon 
Mesh > Clusters > Polygons.

If you have animated the textures, scaling, 
rotation, or transformation, its animation is 
not imported.

Some animated properties may not import 
properly. This is due to the conversion that 
occurs when some SOFTIMAGE|3D 
attributes are converted to mental ray 2.1 
parameters—there may not be a one-to-
one correlation between all parameters.
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3D Textures Yes Some animated properties may not import 
properly. This is due to the conversion that 
occurs when some SOFTIMAGE|3D 
attributes are converted to mental ray 2.1 
parameters—there may not be a one-to-
one correlation between all parameters.

Camera Yes Some animated properties may not import 
properly. This is due to the conversion that 
occurs when some SOFTIMAGE|3D 
attributes are converted to mental ray 2.1 
parameters—there may not be a one-to-
one correlation between all parameters.

Lights Yes Sun light-types are not supported. They’re 
converted to Infinite lights.

Area lights whose geometry is disabled will 
import with U and V values set to 0.

Some animated properties may not import 
properly. This is due to the conversion that 
occurs when some SOFTIMAGE|3D 
attributes are converted to mental ray 2.1 
parameters—there may not be a one-to-
one correlation between all parameters.

Depth-fading Yes Depth-fading is imported as the soft_fog 
shader.

Some animated properties may not import 
properly.

Fog Yes Fog is imported as the soft_fog shader.

Ambience Yes Ambience is imported as ambient lighting.

Palettes No

Render Settings Yes

Photon Director Yes

FXDirector Yes Freeze the effect before importing.

ToonAssistant Yes Freeze the effect before importing.

Element Imported? Notes and exceptions Workarounds
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Animation

Element Imported? Notes and exceptions Workarounds

Skeletons Yes Chains loaded from a SOFTIMGE|3D scene 
will retain their original hierarchical 
structure. The effectors’ orientation and 
position will also remain global, not local.

See Character Rigs on page 22 for more 
information.

SRT Animation Yes

Cluster Yes Clusters are deleted unless they belong to 
a NURBS or polygon object.

Expressions applied to clusters do not 
import.

Shape Yes Shapes are converted to clusters.

Expressions applied to shape-animated 
objects do not import.

Lattice Yes Lattice animation is converted to cluster 
animation.

Lattice animation transition curves may 
not be exactly the same as in 
SOFTIMAGE|3D. Make sure extrapolation 
is set to weighted.

Path Yes If the original path is a closed B-spline, 
when it is converted to a NURBS curve, 
the first control point may not be at the 
same position as the original curve. 
Convert the curve to NURBS in 
SOFTIMAGE|3D first—you’ll have the 
same problem, but you can adjust it 
before importing.

Constraints: 
positions, 
orientation, 
direction, 
scaling, 
bounding plane

Yes In SOFTIMAGE|3D you could pick either 
another object (any other object) or use 
world space as the reference for the 
positional constraint. XSI only recognizes 
the parent object as a valid reference for a 
positional constraint. 

Constraints: 
Position and 
rotation limits

Yes

Tangency Yes XSI only imports one type of tangency: if 
the object is on a path and is constrained 
to be tangent to the curve on that path. 
The two other types of tangency 
constraints available in SOFTIMAGE|3D (as 
described in the SOFTIMAGE|3D Reference 
guide under Constraint > Tangency) are 
not imported.

Constraints: 
Cluster to 
object, Object to 
cluster

Yes Object to cluster is imported as a cluster 
centre.
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Constraints: 
Cluster centre, 
two and three 
points

Yes

Constraints: Up 
vector

Yes Imports if coupled with IK chain, path 
animation, direction constraint, or two 
point constraint.

Normal to 
surface 

No

Expressions Yes The complete syntax is imported. If a 
variable is encountered it is expanded and 
placed in the expression syntax. However, 
“has relation” is not imported.

Expressions applied to shape animated 
objects do not import.

Expressions applied to clusters do not 
import.

Expressions applied to instances are not 
imported. 

Expressions applied to materials and 
textures may not be imported. 

Fcurves Yes Deactivated fcurves (set in the DopeSheet) 
are imported as activated.

Deformations Yes Deformations by curve and surface are 
imported, but may not display the same 
results.

Wave No

Flock Yes

Dynamics No

Simulation No

Quick Stretch No

Controls No

Collisions No

Animated 
Booleans

No

Channels No

Element Imported? Notes and exceptions Workarounds
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Audio No Refer to the command log for information 
about any sound files associated with the 
imported scene. Refer to the Chapter 13: 
Audio chapter of the XSI Animating guide 
for information about re-loading the 
audio file. 

Actions No

Element Imported? Notes and exceptions Workarounds
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